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Quasi-2D airfoil 

This tutorial will show the entire process flow of a typical BOXERmesh project for creating a solvable, 
refined mesh on a quasi-2D aerofoil section. This includes specifying a bounding box and region, setting 
edge and face refinement levels, patch creation and defining a viscous layer mesh. After the mesh 
sizing and refinement parameters are specified, the mesh is created, visualised and saved to file. 

Import the geometry from the naca0012_fine.btf file  

• File > Import Part from the menu bar; or 

• Click the Import Part button; or  

• Use the keyboard shortcut Ctrl-G 

The geometry in this example is imported as a single part containing one patch ("naca0012").  

 

Set the Bounding Box to define the extent of the mesh domain  

• Double-click the Bounding Box item in the feature tree, or click on the Bounding Box 

button in the toolbar to open the Bounding Box Editor. 

• Using the Constraint: Enclosing Box option (pull down menu item), set the 

coordinates of Corner 1 to (-2.0, -1.0, 0.5) and Corner 2 to (3.0, 1.0, 0.6) to make a 

'thin' slice which intersects the geometry. Set the Length Scale to 0.05. Note that the 

Actual Bounding Box dimensions are the same as the specified dimensions because 

the length scale is an integer multiple of the Bounding Box x, y and z extents.  

• Press OK to confirm the Bounding Box specification.  

The Bounding box appears in the scene, subdivided by lines at the Length Scale that you have just 

specified. 
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Use the right mouse button menu over the Bounding Box entry in the Feature Tree to hide, show and 
change the display type of the Bounding Box in the scene. The Display Panel with the Micro toggle 

activated, can be used to hide selected regions of the Bounding Box object (when used with Ctrl-LMB). 

 

Create a Region  

• Click on the Create new Region button in the toolbar, or go Insert > Region to open 

the Region Editor dialog. 

• For the mesh to generate in the correct region of space and be correctly bounded, the 
Region's seed point must be placed inside the Bounding Box, but outside the envelope of 
the geometry and any octree cells that the geometry cuts through. Its exact position is not 
important providing it meets these two criteria. Set the position of the seed point as (1.27, -
0.75, 0.55). Leave the name of the Region as default Region.  

• Press OK to confirm the Region specification. The Region is shown via its seed point, 

which shows as a quartered circle in the 3D scene and Region appears in the Feature 

Tree. 
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Create a 'general' level of mesh refinement at all faces  

Note:  

The tutorial here explicitly moves patches into the Feature Tree Subset to demonstrate how to 

interact with it. For general usage remember that having no patches in the tree is the same as 
having all patches in the tree; and that having some patches limits the refinement to faces in any of 
those patches.  

Subsetting faces within volume entities (polylines and volumes) works along similar lines. If there 
are no volumes then no volume subsetting is done; if there are some volumes then the subset 
includes faces in any of those volumes. 

• Click on the Face Refinement button in the toolbar, or go Insert > Face Refinement 

Specifier to open the Face Refinement Editor dialog.  

• With the Level radio button selected, enter 3 in the Level field. The Length field is 

automatically updated to show that the cell edge length at octree level 3 will be 0.00625. 

• Drag the patch that contains all the geometry ("naca0012") from the feature tree and drop 
it in the Feature Tree Subset in the Face Refinement Editor. Leave the name of 

the Face Refinement as default Face Specifier.  

• Press OK to confirm the Face Refinement specification. Face Specifier appears in the 

Feature Tree.  
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Specify a higher level of refinement in regions of high curvature  

• Click on the Edge Refinement button in the toolbar, or go to Insert > Edge 

Refinement Specifier to open the Edge Refinement Editor dialog. 

• With the Level radio button selected, enter 5 in the Level field. The Length field is 

automatically updated to show that the cell edge length at octree level 5 will be 0.0015625.  

• Un-check the Minimum Angle Deviation (degrees) tickbox. 

• Check the Maximum Radius of Curvature tickbox and enter 0.1 in the Radius field.  

• Drag the patch that contains all the geometry ("naca0012") from the feature tree and drop 
it in the Feature Tree Subset in the Edge Refinement Editor. Leave the name of the 

Edge Refinement as default Edge Specifier. This means that any surfaces in the patch 

naca0012 will have the surface cells refined to level 5 octree IF the local radius of 

curvature of the surface is less than 0.1. This should automatically refine the mesh around 
the high curvature region of the leading edge, whilst leaving the surfaces on the majority of 
the upper and lower aerofoil surface at the 'general' refinement level 3.  

• Press OK to confirm the Edge Refinement specification. Edge Specifier appears in the 

Feature Tree.  
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Create a new patch at the trailing edge and specify refinement level on it  

• Turn off the visibility of the Bounding Box by unchecking the check box next to Bounding 
Box in the Feature Tree.  

• Click the Micro button to enter Micro select mode. The Micro button turns blue. 

• Using Ctrl-LMB to control the selection marquee, highlight approximately the last 10% of 
the blade, including the trailing edge. The selected facets turn yellow. 

• Whilst the selected facets are yellow, click and hold RMB and select Assign to Patch 

OR click on the Assign to Patch icon on the toolbar. The Patch Assignment dialog box 
appears. 

• Only one patch currently exists - we want to put the highlighted region into a new patch 
called trailingEdge. Click on the part name ("naca0012_fine") directly below the 

Parts heading in the Patch Assignment dialog box. The New Patch button becomes 

active. 

• Click the New Patch Button and enter the name trailingEdge instead of the 

placeholder name Patch2.  

• Click OK. The patch trailingEdge appears in the Feature Tree. 

• Following the steps for face refinement specification above, create a new Face Refinement 
specifier called teRefinement at level 5 octree for the patch trailingEdge. 
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Specify the viscous layer mesh  

• Click on the Layers button in the toolbar, or go Insert > Layers Specifier to open 

the Body-fitted Layer Editor dialog. 

• Enter 5 in the Layer Count field and 1.2 in the Expansion Ratio field, to set how 

many viscous layers will be created and the rate at which the cell height, normal to the 
surface, increases. 

• With the Relative radio button selected, enter 0.1 in the Initial Step Size field. 

This implies that the height of the first near-wall cell will be (0.1 x local cell edge length).  

• Drag the all patches that contain the geometry ("naca0012" AND "trailingEdge") from the 
Feature Tree and drop them in the Feature Tree Subset in the Body-fitted Layer 

Editor. Leave the name of the layer as default Layer. This means that any surfaces in the 

patches naca0012 and trailingEdge will have a viscous layer mesh applied as 

specified in the steps above. 

• Press OK to confirm the layer specification. Layer appears in the Feature Tree. 

Generate and view the Octree Mesh  

• Click on the Generate Octree mesh button in the toolbar (the button goes orange to 
indicate that BOXERmesh is busy) 

• When the octree mesh is complete, the Generate Octree Mesh button goes grey and its 
action is disabled to indicate that the octree is up-to-date. 

• The internal octree patches appear in the scene and also appear as features in the 
Feature Tree (Octree > Patches > naca0012 and trailingEdge). 
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• Click on the Generate New Isosurface button in the toolbar, or go Insert > 

Isosurface to open the Isosurface Editor dialog.  

• Change the Mesh type to Octree, change the Cut Type to Isosurface and change the 

Iso Scalar to Z Coordinate. 

• Enter an Iso Value of 0.55 and click OK. A cut plane through the Octree volume mesh 

appears at Z=0.55 

• The item Isosurface appears in the Feature Tree under Visualisation > 
Isosurfaces 
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Generate and view the Inviscid mesh  

• Click on the Generate Inviscid Mesh button in the toolbar (the button goes orange to 
indicate that BOXERmesh is busy) 

• When the mesh is complete, the Generate Inviscid Mesh button goes grey and its action is 
disabled to indicate that the mesh is up-to-date. 

• The surface mesh patches appear in the scene and also appear as features in the Feature 
Tree 

• Double-click on Isosurface in the Feature Tree to re-activate the Isosurface Editor for 

this feature. 

• Change the Mesh list picker from Octree to Body-Fitted and click OK. The visualisation 

changes to show a slice through the body-fitted mesh. 

 

Generate and view the Layered mesh  

• Click on the Generate Layered Mesh button in the toolbar (the button goes orange to 
indicate that BOXERmesh is busy) 

• When the mesh is complete, the Generate Layered Mesh button goes grey and its action 
is disabled to indicate that the mesh is up-to-date. 

• The Isosurface updates and the layers can now be seen. 

mailto:info@boxersolutions.com
http://www.boxersolutions.com/


 

Page | 9  Quasi-2D Airfoil 

info@boxersolutions.com  www.boxersolutions.com 

 

Reduce the overall volume cell count by allowing cells to be anisotropic  

By allowing the cells to be 'stretched' in the streamwise (X) direction we can reduce overall cell count 
by filling the domain space more efficiently. 

• Click on the Anisotropy button in the toolbar or go to Insert > Anisotropy 

Specifier to open the Body-fitted Anisotropy Specifier Editor. 

• Ensure that the x direction checkbox is checked and that the y and z checkboxes are 

unchecked. 

• Leave the Feature Tree Subset empty. 

• Press OK to confirm the Anisotropy specification. Anisotropy appears in the Feature 

Tree. 

• Regenerate the layered mesh by clicking on the Generate Layered Mesh button in the 
toolbar (the button goes orange to indicate that BOXERmesh is busy).  Note that pressing 
this button re-generates both the inviscid mesh and the layered mesh. 

• When the mesh is complete, the Generate Layered Mesh button goes grey and its action 
is disabled to indicate that the mesh is up-to-date. 

Note the change in the shape of the farfield mesh elements (automatically updated on the isosurface). 

Extrude the bounding box cell faces to the far field and extrude the wingspan  

• Click on the Bounding Box Extrusion button in the toolbar or go to Insert > Extrusion 

Specifier to open the Body-fitted Extrusion Editor. 

• Change the name of the specifer from Extrusion to upstream in the Name: field. 

• From the Direction: pull-down menu select x_min. 

• From the Calculated: pull-down menu select Total Distance. 

• In the Extrusion Count: field enter 10. 

• In the Initial Plane Distance: field enter 0.15. 

mailto:info@boxersolutions.com
http://www.boxersolutions.com/


 

Page | 10  Quasi-2D Airfoil 

info@boxersolutions.com  www.boxersolutions.com 

• In the Expansion Ratio: field enter 1.14. 

• Press OK to confirm the extrusion specification. upstream appears in the Feature Tree, 

and a graphic preview of the extruded cell distances and rate of expansion appears on the 
x_min face of the Bounding Box. 

• Click on the Bounding Box Extrusion button in the toolbar or go to Insert > Extrusion 

Specifier to open the Body-fitted Extrusion Editor again. 

• Change the name of the specifer from Extrusion to span in the Name: field. 

• From the Direction: pull-down menu select z_max. 

• From the Calculated: pull-down menu select Initial Plane Distance. 

• In the Extrusion Count: field enter 14. 

• In the Expansion Ratio: field enter 1. 

• In the Total Distance: field enter 4. 

• Press OK to confirm the extrusion specification. span appears in the Feature Tree, and a 

graphic preview of the extruded cell distances and rate of expansion appears on the 
z_max face of the Bounding Box. 

• Generate the extruded mesh by clicking on the Generate Layered Mesh button in the 
toolbar (the button goes orange to indicate that BOXERmesh is busy).  

Note:  

Bounding box extursions are only created after the ‘final’ meshing step – if a layer specification is 
active in the feature tree then bounding box extrusion is only done after layering. 

• When the extrusion is complete, the Generate Layered Mesh button goes grey and its 
action is disabled to indicate that the mesh is up-to-date. 

 

Save the mesh (*.box) on the server filesystem 

• Go to Insert > Mesh Export and select BOX to open the BOX Mesh Export Editor 

dialog. Alternatively, click the Create new BOX mesh export specification icon 

on the toolbar. 

• Leave the name as default BOX Mesh Export. 

mailto:info@boxersolutions.com
http://www.boxersolutions.com/


 

Page | 11  Quasi-2D Airfoil 

info@boxersolutions.com  www.boxersolutions.com 

• Click on the disc icon to open a file browser. Navigate to the working directory, enter the 
filename naca0012 and check the Automatically Save with File-Extension 

(*.box) tick box. Click Save. 

• Ensure the Enabled tick box is checked. 

• Drag the region that contains the mesh (Region) from the Feature Tree and drop it in the 

Exported Regions Subset in the BOX Mesh Export Editor. 

• Click OK to exit. 

• Click on the Save all body-fitted mesh exports button in the toolbar, or 

• File > Save all mesh exports from the menu bar. 

Save the geometry file (*.btf)  and the project file (*.bxr) on the client filesystem  

• Save from the menu bar, OR  

• Click on the Save Project icon on the toolbar, OR 

• Keyboard shortcut Ctrl-S. 

• The geometry must be saved before the project and a pop up window informs the user of 
this.  Click OK and save the the geometry (*.btf) file. 

• The Save Project As window now opens.  Click on the Project disc icon to open a 

file browser. Navigate to the working directory, enter a project filename and check the 
Automatically Save with File-Extension (*.bxr) tick box. Click Save. 

• If you wish to save a .bmf file then check the Mesh tick box. 

• Click on the .bmf disc icon to open a file browser. Navigate to the working directory, enter 

a .bmf filename and check the Automatically Save with File-Extension 

(*.bmf) tick box. Click Save. 

• Click OK to save the project file and .bmf file. 

 

Note:  

If the geometry has changed (e.g. by patch assignation), then the .btf file will also be saved during 

the Export process. 
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