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Thin geometry multiregion mesh  

Note:  

This tutorial is similar to the first multiregion mesh case, but shows how special consideration must 
be given to thin regions when working in multiregion mode. 

In this case we will produce a four-region conformal mesh; a "fluid" exterior, and three meshes for solid 
components blade1, blade2 and a propeller hub.  

This tutorial assumes that the user is familiar with the general method of the BOXERmesh GUI, and the 
operation of the various specifier panels. If this is not the case then please review earlier tutorials.  

Import the geometry from the *.btf file propeller.btf 

• File > Import Part from the menu bar, OR 

• Click the Import Part toolbar button, OR  

• Use the keyboard shortcut Ctrl-G 

The geometry is imported as a single part containing five patches. The blades are connected to the hub 
at the "interface" patches. 

Define the Bounding Box to specify the geometric limits of the mesh 

The Bounding Box is set to create a fluid region surrounding all the solid components. 

• In the Bounding Box Editor, set the Coordinate System to Cartesian (the default) 

and the Constraint to Enclosing Box. 

• Set Corner 1 to (-0.1, -0.45, -1.425) and Corner 2 to (0.35, 0.45, 1.425). Set the 

Length Scale to 0.075. The Actual Bounding Box dimensions remain unchanged, 

because we can fit an integer number of cells at length scale 0.075 exactly to the specified 
Bounding Box extent in x, y and z.  

• Click OK to confirm the Bounding Box specification.  

The Bounding Box appears in the scene, subdivided by lines at the length scale just specified. 
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Create Regions  

In this case there are four regions; the solid of each component, and the surrounding fluid. The regions 
are explicitly defined by placing a Region Seed Point within each volume. Any volume which is not in 
communication with a Region Seed Point will not be meshed (just like with single region meshing).  

Create four Regions: 

• Define a Region called "blade_one" with a seed point at (0.1,-0.025, 0.25). 

• Define a Region called "blade_two" with a seed point at (0.1, 0.02, -0.25). 

• Define a Region called "hub" with a seed point at (0.1, 0.035, 0.035). 

• Define a Region called "exterior_fluid" with a seed point at (0.1, 0.2, 0.2). 

  

Create Polylines to refine the blade leading and trailing edges 

Two polylines must be created to allow refinement of only the leading and trailing edges of the propeller 
blades. 

• Click Create a new Polyline specifier, and clear the default coordinates to leave an empty 
Centreline list. 

• Click the From 3D button and select points along the leading and trailing edge of the 

surface of the “blade1” geometry using Ctrl-LMB.  Consecutive Ctrl-LMB clicks will 
automatically add subsequent points to the centreline list. 

• Change the Radius to 0.0125 and the Type to Sphere Capped. 

• Click OK to confirm the Polyline specification. 

• Repeat the procedure and create a second polyline for the “blade2” leading and trailing 
edges. 

Set the level of Edge and Face Refinement on the geometry  

Multiregion meshing allows the use of variable mesh refinement. So in this case we can specify one 
'general' level of refinement for all the faces and then a higher level of refinement to capture edges. 

• Create a Face Refinement Specifier for all the patches, at octree level 3.  

• Click OK 
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• Create an Edge Refinement Specifier for all the geometry patches. Set the octree level of 
the refinement at 4.  

• Set the Maximum Radius of Curvature to 0.05. 

• Leave the Minimum Angle Deviation checkbox unchecked. 

• Specify Apply to: Whole patches 

• Leave the Feature Tree Subset empty. 

• Click OK 

• Create a second Edge Refinement Specifier for all the geometry patches. Set the octree 
level of the refinement at 5. Set the Maximum Radius of Curvature to 0.005. 

• This Feature Tree Subset can remain empty – meaning that the refinement is applied to 
any facet on any patch.  Highlight the two polylines in the feature tree and drag and drop 
these into the Edge Specifier Feature Tree Subset.  This means that the refinement will 
now be applied to any facet on any patch contained within the polyline envelopes 

• Click OK 

• Click the Show Octree preview button in the toolbar. The Octree indicators appear on the 
geometry surface facets 

 

Define the thin Regions 

The two propeller blades are 'thin' in relation to the local cell edge length - therefore we must flag 
surfaces which create the thinness and tell BOXERmesh to preserve the mesh region between these 
surfaces during body-fitted meshing.  

• Double-click on the "blade_one" region in the Feature Tree to activate its Region Editor. 

• In the Region Editor, check the Include Patches checkbox. A patch subset box 

appears. 

• From the patch list in the Feature Tree, drag the patch "blade1" into the Region Editor 
patch subset list. 

• Click OK to confirm the updated Region specification. 

• Repeat the above for the "blade_two" region, using the geometry patch "blade2". 
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The "exterior_fluid" and "hub" regions are not 'thin' so they do not require any special patch flagging. 

 

Define viscous layer cells for the fluid Region 

In multiregion meshing you must define not only which surfaces should be used to extrude layers from, 
but also into which region the layers should extrude. In this case we want the layers to extrude into the 
fluid region, not the solids. 

• Create a Layer Specification using Layer Count as 6, Expansion Ratio as 1.3, and 

Initial Relative Step Size as 0.1. 

• Drag the "exterior_fluid" region from the feature tree into the Layer Specifier Feature 

Tree Subset. 

• Leave the Perimeter Patches checkbox unchecked. 

• Click OK to confirm the Layer Specification.  
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Note:  

 If the Layer Specifier Feature Tree Subset does not contain a Region, BOXERmesh assumes 

that the first region on the Feature Tree list is the one which is specified and thus the one to get 
layered. (In this case it would be "blade_one", as that was the first region to be created).  

Note:  

By leaving the Feature Tree Subset empty but with a defined Region Point in the Layer Editor, 

this tells BOXERmesh to extrude layer cells from all the surfaces in contact with the specified 
region.  

Generate and view the Inviscid mesh 

• Click on the Generate Inviscid Mesh button in the toolbar (the button goes orange to 
indicate that BOXERmesh is busy) 

• When the mesh is complete, the Generate Inviscid Mesh button goes grey and its action is 
disabled to indicate that the mesh is up-to-date. 

• The surface mesh patches appear in the scene and also appear as features in the Feature 
Tree. Turn off visibility of the octree mesh patches to see the body-fitted mesh clearly. 

• Create an Isosurface at y=0, showing the body-fitted mesh as a crinkle-cut. Under the 
Visualisation properties for the Isosurface, change the Type to Scalar, and the Display 

to Face and Edge.  

• In the Rendering Panel, change the Scalar to Analysis region, and click the Render 

by Scalar button on the toolbar. Turn off the visibility of Body-fitted Patches and inspect the 
interface at the fluid-solid boundaries and the hub-blade interface, and note the 1:1 match 
between the meshes.  

• You might wish to turn on the Layer preview at this stage and view an indication of the 
defined layer extrusion pattern on the surface mesh facets (turn on Body-fitted Patches to 
view) 
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Generate and view the Layered mesh 

• Click on the Generate Layered Mesh button in the toolbar (the button goes orange to 
indicate that BOXERmesh is busy) 

• When the mesh is complete, the Generate Layered Mesh button goes grey and its action 
is disabled to indicate that the mesh is up-to-date. 

• The Isosurface updates and the layers can now be seen. 

 

Using Void Regions  

The user may not require the interior mesh of some components in a multiregion mesh and so it would 
seem reasonable to leave the interior region unseeded.  However, if the component is a thin feature 
then a Void region will need to be added in order to preserve the thin feature during meshing. 

If we want to preserve thin features in a multiregion mesh but do not want to create the interior mesh 
inside those thin features, we must define them as void Regions. 

• Click on the "Create new void Region" button on the toolbar; the Void Region Editor 
appears. 

• In the Name field, rename from the default name to "blade_one_void". 

• Check the Include Patches checkbox. A patch subset box appears. 

• From the Parts list in the Feature Tree, drag the patch "blade1" into the Void Region Editor 
patch subset list. 

• Click OK to confirm the Void Region specification. "blade_one_void" appears in the Feature 

Tree under the "Regions" branch. 

• Note:  It is not necessary to specify a location for the Void Region Seed points 

• Delete the original "blade_one" region from the Feature Tree. 

• Again click on the "Create new void Region" button on the toolbar; the Void Region Editor 
appears. 

• In the Name field, rename from the default name to "blade_two_void". 

• Check the Include Patches checkbox. A patch subset box appears. 
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• From the patch list in the Feature Tree, drag the patch "blade2" into the Void Region Editor 
patch subset list. 

• Click OK to confirm the Void Region specification. "blade_two_void" appears in the Feature 

Tree under the "Regions" branch. 

• Delete the original "blade_two" region from the Feature Tree. 

Tip:  

A void region can be used to remove mesh from specified parts of the conjugate mesh if the 
conjugate seed is used.  

Regenerate and view the mesh 

• Click on the Generate Layered Mesh button in the toolbar (the button goes orange to 
indicate that BOXERmesh is busy) 

• When the mesh is complete, the Generate Layered Mesh button goes grey and its action 
is disabled to indicate that the mesh is up-to-date. 

• Inspect the existing Isosurface and note that the interior mesh for the blades has not been 
created, but the thinness of the blade features remains. 

 

Save the meshes (*.box format in this case) on the server filesystem 

• Go to Insert > Mesh Export and select BOX to open the BOX Mesh Export Editor 

dialog. Alternatively, click the Create new BOX mesh export icon on the toolbar. 

• Leave the name as default BOX Mesh Export. 

• Click on the disc icon to open a file browser. Navigate to the working directory, enter the 
filename fluid_mesh and check the Automatically Save with File-Extension 

(*.box) tick box. Click Save. 

• Ensure the Enabled tick box is checked. 

• Drag the region that contains the fluid mesh ("exterior_fluid") from the Feature Tree and 
drop it in the Exported Regions Subset in the BOX Mesh Export Editor. 

• Click OK to exit. 
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• Repeat the steps above creating a second Mesh Export, using filename hub_mesh but 

this time dragging the solid mesh ("hub") into in the Exported Regions Subset in the 

BOX Mesh Export Editor. 

• Click on the Save all body-fitted mesh exports button in the toolbar, or 

• File > Save all mesh exports from the menu bar. 

• Check that you now have a .box file for each of the fluid and solid meshes. 

Save the project file (*.bxr) on the client filesystem  

• Save from the menu bar, OR  

• Click on the Save Project icon on the toolbar, OR 

• Keyboard shortcut Ctrl-S. 

• Click on the Project disc icon to open a file browser. Navigate to the working directory, 

enter a project filename and click Save. 

• If you wish to save a .bmf file then check the Mesh tick box. 

• Click on the .bmf disc icon to open a file browser. Navigate to the working directory, enter 

a .bmf filename and check the Automatically Save with File-Extension 

(*.bmf) tick box. Click Save. 

• Click OK to save the project file and .bmf file. 

Save the meshing session to a script file (.lua) to enable batch meshing 

• Click on the Edit Body-Fitted Mesh button in the toolbar. 

• Check the Save BOXERmesh file in Script checkbox. 

• Enter names for the fluid and solid meshes (*.bmf) in the file picker. 

• Click OK. 

• Click on the Export Mesh Process to Script button on the toolbar, or 

• File > Write batch script from the menu bar. 

• Select either the local (client) or the remote (meshing server) filesystem. 

• Enter the filename and an optional directory path for the output script file. 
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