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Erosion of a Francis Turbine Guide Vane

This example demonstrates the BOXERgeom physics-based level-set morphing capabilities for
generating the degraded geometry of a hydro-turbine component due to sand erosion. The initial
geometry is a ring of guide vanes from the Francis Turbine test rig that is housed in the Waterpower
Laboratory at the Norwegian University of Science and Technology. Erosion rates on the geometry
surfaces were sourced from CFD calculations that utilise Discrete Phase Modelling and the Finnie
erosion model. Flow field results were obtained at operating conditions for the turbine’s best efficiency
point (12,000 LPM) and particle transport conditions represented sand flow rates on the Bhilangna river
in the Himalayas during monsoon season (12-million tons/year). The steps to generate the erosion rates
are not included here as the tutorial focusses on the capabilities of BOXERgeom. The erosion rates are
stored in an ASCII-encoded, column-format file, which drives the geometry degradation.

We used the test-case provided by NTNU — Norwegian University of Science and Technology under
the Francis-99 workshop series: https://www.ntnu.edu/nvks/francis-99

Prerequisites

This tutorial assumes that the user is familiar with the general method of the BOXERmesh GUI, and the
operation of the various specifier panels. If this is not the case, then please begin a BOXERmesh
tutorial.

The following files are required to complete the tutorial:
e francis turbine guide.btf

e ecrosion guide vane.dat
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Implementation within a Workflow

The following diagram illustrates an example workflow that can be implemented to model component
erosion with the tools that are available in BOXERgeom and BOXERmesh. The process can be fully-
or semi-automated thanks to the Lua-scripting capabilities in BOXER. The link between BOXERgeom
and BOXERmesh is seamless and fully parallel, which minimised the turnaround time of the workflow
process.

This example uses CFD modelling to determine erosion rates on the turbine components, but other
methods may be used, such as direct measurements of in-service parts.
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Speed Function File Format

The speed function (in this case erosion guide vane.dat), which drives the physics-based
morphing in BOXERgeom is expected to be an ASCII-encoded, column-format file (either space or tab
delimited). The five columns are a unique ID, x-, y-, z-location, and the speed function value (in this
case erosion rate; eroded volume per surface area per second — m3/m?/s or m/s). Note that these values
do not need to be defined at each point in the level-set explicitly. BOXERgeom will interpolate the values
from the speed function file to the component surface based on the closest point.

In this example, the erosion was post-processed from the CFD solver into the correct format using the
capabilities that are available in Paraview v5.7 (Kitware, New York, USA). In your own cases, surface
data will also need to be converted into speed function files, but this is outside the scope of this tutorial.

An example of the speed function file used in this tutorial, with the columns annotated, is given below:

3 erosion_guide_vane - Notepad = | X
Fle Edit Format View Help x-location y-location z-location
00000192 -29.415@/ —11.@@57/ 345,7217 0.0000 ~
00000193 -29.4150 -11.0636 346.7669 0.0202
00000104 -29,4150 -9.,9927 346.8162 | _SPeed |5 g335
00000195 -29.4150 ~10.0144 347.8496 | fUNction |5 5199
00000196 -29.4150 -11.0686 347.8075 0.0225
00000197 -29,4150 -8.9092 344,7599 0.0216
0000198 -29,4150 -7.8871 344.8118 0.0243
00000199 -29.4150 -7.9001 345.8569 0.0238
00000200 -29,4150 -8.9256 345,8188 0.0240
00000201 -29,4150 -8.9513 346.8556 0.0181
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Importing the geometry
e File > Import Part from the menu bar, OR
e Click the “Import Part” toolbar button, OR
e Use the keyboard shortcut Ctrl-G

e Open francis_turbine guide.btf from the file browser

& Explicit Edges
Mesh

isualisation
Isosurfaces
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Setting up the octree ®

The physics-based level-set morphing operates in the same domain (bounding box) and with the same
resolution as the octree mesh. Due to the circular shape of the guide vane ring, we can utilise the
cylindrical bounding box capabilities that are available in BOXER. To reduce processing times, we will
define the bounding box to cover only two of the 28 guide vanes and centre it on a singular guide vane
that will be eroded. The number of cells is set to achieve a cell size of approximately 2, which is sufficient
to model the degraded geometry surfaces — the mesh resolution can be increase for high fidelity CFD

models.

e Set Coordinate System to: Cylindrical
e Set Corner 1 to: (-35 -7 325)

e Set Corner 2 to: (35 18.7153 381)

e Set Number of Cells to 80
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Defining the fluid region

e Create a Region and set its seed point coordinates to be (0 35 365)

Fle Edit View [nset Help
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Setting a face refinement on specific patches

o Create a Face Refinement Specifier on patch "guide_vane" at octree level 2
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O
A

Creating a physics-based level-set morph specification ®)

This step demonstrates the main objective of this tutorial — to set up a physics-based level-set morph
to model component degradation from sand erosion. The upper limit on the number of iterations is set
to 15 to control the maximum amount of erosion on the guide vane geometry. We also use a fixed time
step for the level-set operation, so that the distance the geometry morphs is consistent between each
iteration. Initially, we look at the resultant geometry at Iteration 10, before increasing the amount of
erosion in the next step.

e Insert > Level-set editing > Morphing from the menu bar, OR
o Click the “Create new level set editing morphing specifier” toolbar button
e SetNameto Physics Morph
e Select the Physics radio button
e Drag-drop francis turbine guide from the Feature Tree to Source field in the Editor
e Open the External Data file browser to select a surface based scalar file
o Selecterosion guide vane.dat as the data file
e Under lteration:
o Tick the checkbox and set Max to 15
o SetValue to 10
e Under lteration Controls:

o Tick the Initial Time Step checkbox, set the time step to 0.2, and tick the Fixed Time
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O
A

Creating a smoothing level-set morph specification @)

The output surface from the physics-based level-set morphing operation can often be irregular due to
the input and deformation of the surface. Therefore, the smoothing morph capabilities can be used to
generate a more regular surface for the eroded surface. In this example, two smoothing iterations are
sufficient to reduce the surface irregularities to an acceptable level.

e Insert > Level-set editing > Morphing from the menu bar, OR
o Click the “Create new level set editing morphing specifier” toolbar button
e SetName to Smoothing Morph
e Select the Smoothing radio button
e Drag-drop Physics Morph from the Feature Tree to Source field in the Editor
e Under lteration:
o Tick the checkbox and set Max to 2
o Set Value to 2

o Tick the “Regenerate octree from this operation” checkbox
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|
Generating the Physics Based Level-set morph 4

Press the “Generate Level-set” button on the toolbar (the button goes orange to indicate that
BOXERgeom is busy)

When the Level-set calculation is complete, the Generate Level-set button goes grey, and its
action is disabled to indicate that the Level-set is up to date

o The operation takes approximately 25 minutes on 6 CPUs

The Level-set surface appears in the scene at slider position 10 for the physics morph and 2
iterations of geometry smoothing

In the Feature Tree, under Smoothing Morph, select the top, bottom, and guide vane
patches, then right-click and select Only

Select the top, bottom, and guide vane patches again, then right-click and select Show
Faces
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Regenerating the Level-set morph at a new slider position

Here we demonstrate the effect that changing the specification of an upstream level-set operation has
on downstream operations. In this tutorial, the smoothing morph is dependent on the physic-based
morph, so changes to the physics-based morph cause the smoothing morph to out of date. For example,
the smooth morph currently represents the smoothed surface of the eroded geometry at Iteration 10.
Moving the slider value for the physics-based morph to show a different state of erosion means the
smoothing morph must be recalculated, as its input has changed. The time to complete this operation
will be less than the previous step, as the physics-based morph does not need to be recalculated
because its input (the original geometry) has not changed.

e In the Feature Tree, right-click Physics Morph and select Edit Properties
e Click-and-drag the lteration slider to its maximum position (Value: 15)

o The LevelSet Editing branch in the Feature Tree shows a warning triangle to indicate
that the operation is now out of date

o This slider position corresponds to approximately a year’s worth of erosion based on
the operating conditions in the CFD model

e Click the “Generate Level-set” button on the toolbar

o As only the smoothing morph needs to be updated, the operation takes less time than
before (approximately 4 minutes on 6 CPUs)
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Generating a mesh
e Press the ‘Generate Inviscid Mesh’ button
o This operation takes approximately 15 minutes on 6 CPUs

o BOXERmesh generates a volumetric body-fitted mesh around the Level-set shape at
slider value 15 in the normal way.

o This mesh can have layers added/be extruded/be exported for analysis in the normal
way
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Exporting the mesh

Finally, we export the mesh to be run in a CFD solver. In this example, we export to BOX-format file,
but the process is similar for other file formats. This demonstrates how an iterative process of: geometry
— flow — degradation — mesh — flow — repeat. For example a mesh at three months’ degradation
can be exported and solved to determine how the eroded geometry affects erosion rates, and so on.

Page | 12

Goto Insert > Mesh Export and select BOX to open the BOX Mesh Export Editor
dialog. Alternatively, click the Create new BOX mesh export specification icon
on the toolbar.

Leave the name as default BOX Mesh Export.

Click on the disc icon to open a file browser. Navigate to the working directory, enter the
flename guide vane and check the Automatically Save with File-Extension
(*.box) tick box. Click save.

Ensure the Enabled tick box is checked.

Drag the region that contains the mesh (Region) from the Feature Tree and drop it in the
Exported Regions Subset in the BOX Mesh Export Editor.

Click OK to exit.
Click on the save all body-fitted mesh exports button in the toolbar, or

File > Save all mesh exports from the menu bar.
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LIABILITY

BOXERsolutions Ltd ("The Company") has used all best endeavours to ensure the accuracy
of the work performed and any information given, but the Company makes no warranty,
express or implied, as to accuracy and will not be liable for any consequences arising out of
any inaccuracies or omissions.

The Company excludes all warranties, representations or liabilities to the fullest extent

permitted by law. Without prejudice to the generality of the foregoing the Company excludes
any liability for consequential loss or damage including economic loss, loss of profit, revenue
or goodwiill.
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